Nodejs-Npm Versiyon uyuşmazlığı

Bu yazım oldukça kısa ama bence oldukça işe yarar olacak diye umut ediyorum. Ben ubuntu kullanıcısıyım ve en sevdiğim yani evrensel program kütüphanesi olması. Bütün evrensel araçlar ubuntu windows vb. diye seçenek sunuluyor. Ama bugün 1 saattir bu olayın iğrençliği ile karşı karşıyayım. NPM ve NodeJs paketlerindeki uyuşmazlıklar!!!

Arkadaşlar Nodejs ve NPM paketlerini ubuntu üzerinde

sudo apt-get install nodejs npm

şeklinde çok kolay bir şekilde kuruyorsunuz. Sonra

node -v
npm -v

yapıyorsunuz ama node komutu bazen hata verebilir. Yada tam tersi iterasyonda sıkıntı yaşayabilirsiniz. Çözümü google'ayınca oldukça basit.

ln -s /usr/bin/nodejs /usr/bin/node

Burada aynı işlevi her iki keywords için standartlaştırıyorsunuz.

Hayır hala hatalar bitmedi

Şimdide NPM üzerinde login olmayı deneyin! Olmadı dimi :)Arkadaşlar sürümden dolayı sıkıntı yaşıyorsunuz ve Ubuntu yazılım merkezinde ise oldukça eski bir sürümde kaynak dosyası bulunuyor. Biraz interneti kurcaladım ama maalesef istediğim bir yöntem bulamadım. Sonra ise çok komik birşeyi fark ettim. Npm'de aslında bir npm paketi! Evet kendisini güncellemek için kendisini çağırabiliriz. Evet bencede çok saçma...

npm install -g npm

Bu komut ile artık npm paketiniz güncel sürüme ulaştı! Gece 1'de bu yazıyı benim gibi mağdur olan arkadaşlara itafen yazıyor ve saçma yazılım merkezine güzel temennilerimi (!) sunuyorum.

By @Tolgahan in
Tags : #node not login, #Npm versiyon,

Comments !